Author Topic: Craigslist Stove - Need Help!!!  (Read 503 times)

Neo

  • Stubble
  • **
  • Posts: 135
Craigslist Stove - Need Help!!!
« on: April 15, 2018, 07:05:05 PM »
Mustachians, I need your help, especially those good with electronics or appliances. I bought a used electric glasstop range on Craigslist. I tested it at the seller's house and everything worked. Transported it home in my minivan laying on its side. Smooth trip with no significant bumps or anything. Get it home, take the front door apart a bit to clean in between the glass, then plug it in and suddenly it's getting no power? Nothing works. I plugged the old one back in and it still works. I thought maybe the plug on the new one got damaged so I swapped it with the plug on the old one and still nothing.

I am stumped. Can anyone think of a reason this stove would work at the seller's house and not work when I got it home? I read online that it's okay to transport it on its side and, like I said, it was an uneventful ride home. It's a frigidaire gallery electric glass top stove if that helps.

Thanks for any advice anyone can offer!!!

Neo

  • Stubble
  • **
  • Posts: 135
Re: Craigslist Stove - Need Help!!!
« Reply #1 on: April 15, 2018, 08:03:45 PM »
Solved it. Mods can close.

Gone Fishing

  • Magnum Stache
  • ******
  • Posts: 2719
  • So Close went fishing on April 1, 2016
    • Journal
Re: Craigslist Stove - Need Help!!!
« Reply #2 on: April 15, 2018, 08:24:38 PM »
So what was it?  Breaker?

Neo

  • Stubble
  • **
  • Posts: 135
Re: Craigslist Stove - Need Help!!!
« Reply #3 on: April 15, 2018, 09:57:25 PM »
No the ground wire wasn't hooked up right. On our old stove there was a metal bracket that connected from the white terminal to the ground terminal. The new (used) stove had the bracket just folded over and attached to white terminal in two places. I attached one end of the bracket to the ground terminal and voila - we have power. The weird thing was the new stove worked at the seller's house with that bracket folded over and not touching the ground. I dont understand why it worked when I switched it but it did.