Author Topic: Wrong IPv6 in DNS  (Read 596 times)

Lordy

  • Stubble
  • **
  • Posts: 101
Wrong IPv6 in DNS
« on: March 19, 2017, 02:48:24 PM »
Hello,

I was wondering why the forum was slow for me lately and my Chrome on Mac would always show "Resolving host...".

As I am on an IPv6-enabled connection, Chrome tries to look up both AAAA and A records for forum.mrmoneymustache.com.

Unfortunately, the IPv6 record points to fe80::c4f9:b6ff:fe7a:ed8d and fe80 addresses are not routed (just like 192.168).

Could somebody please fix this? Thanks

Cheers, Lordy

Lordy

  • Stubble
  • **
  • Posts: 101
Re: Wrong IPv6 in DNS
« Reply #1 on: March 20, 2017, 10:35:41 AM »
This seems to have been fixed in the meantime.

Lordy

  • Stubble
  • **
  • Posts: 101
Re: Wrong IPv6 in DNS
« Reply #2 on: March 24, 2017, 01:04:45 PM »
I was too optimistic, this issue still persists

Code: [Select]
; <<>> DiG 9.11.0-P2 <<>> forum.mrmoneymustache.com aaaa @8.8.8.8
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 44078
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;forum.mrmoneymustache.com. IN AAAA

;; ANSWER SECTION:
forum.mrmoneymustache.com. 1145 IN AAAA fe80::c4f9:b6ff:fe7a:ed8d

;; Query time: 41 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Fri Mar 24 20:03:30 CET 2017
;; MSG SIZE  rcvd: 82

JLee

  • Magnum Stache
  • ******
  • Posts: 3539
Re: Wrong IPv6 in DNS
« Reply #3 on: March 24, 2017, 01:53:18 PM »
I'm not sure why they have ipv6 at all...I am guessing someone enabled it accidentally.

Verified from my DNS server as well:

C:\Users\**>nslookup forum.mrmoneymustache.com
Server:  **
Address:  **

Non-authoritative answer:
Name:    forum.mrmoneymustache.com
Addresses:  fe80::c4f9:b6ff:fe7a:ed8d
          45.55.151.63

arebelspy

  • Administrator
  • Senior Mustachian
  • *****
  • Posts: 24535
  • Age: -999
  • Location: Traveling the World
Re: Wrong IPv6 in DNS
« Reply #4 on: March 24, 2017, 05:45:44 PM »
Thanks for finding this (and the person who clicked "report to moderators" to bring it to our attention!)

We did do an IPv6 DNS tweak after the server move to make the forum work with certain ISPs, but not sure what issue that caused that you're seeing.

Looking into it.
We are two former teachers who accumulated a bunch of real estate, retired at 29, and now travel the world full time with a kid.
If you want to know more about me, or how we did that, or see lots of pictures, this Business Insider profile tells our story pretty well.
We (occasionally) blog at AdventuringAlong.com.
You can also read my forum "Journal."

Lordy

  • Stubble
  • **
  • Posts: 101
Re: Wrong IPv6 in DNS
« Reply #5 on: March 25, 2017, 11:13:38 AM »
This might not be an issue for most users, since those who are IPv6 enabled will quickly find that the address is not reachable.

My router is an AVM FritzBox however which notices that the address coming back from the DNS is local (fe80::) and it's DNS rebind protection kicks in.
It discards the record it received and lets my client (Chrome on Mac) run into a timeout instead. After the time-out, it tries IPv4 which works fine.

Hope this helps,
  Lordy