Author Topic: Laptop and wifi issues  (Read 699 times)

dodojojo

  • Pencil Stache
  • ****
  • Posts: 540
Laptop and wifi issues
« on: January 27, 2016, 06:27:33 PM »
I switched from DSL to cable this week--saving $20 a month and increasing my speed from 1-3mbps to up to 25mbps. 

I'm using a retail modem and router rather than the cable company's equipment.  Long story short, I usually average around 29-30 mbps on speed tests for wifi.  Which is lovely since I used to get about 2.5 on DSL.  But my wifi speeds is very unstable, sometimes dropping to .3mbps (yes there's a point there) and where I can't even get the google search page to load.  All this is happening on my Work Laptop. Initially I thought this must be the fabled cable problem where everyone comes home and overloads the system.  But I get speed dropoffs during the day too. 

Yesterday, I switched from 2.4Ghz to 5Ghz to see if that would help.

Today, during one of these dropoffs, I plugged the ethernet cable into my Work Laptop and speeds shot back up....Hmmm, so the culprit is my router?  The modem should be working fine if I'm getting the right speed via cable. I called the company that sent me the router and they agreed to send a new one out.

I do a little more testing.  I downloaded a speed testing app to my phone and I'm getting 30mbps on my phone.  This is while I can't even get the speed test to run on Work Laptop.

So I fire up the seldom used Personal Laptop and I'm getting 30mbps on it too.  Hmmm....

The ping stats for the following:

Work Laptop 238ms
Phone: 19ms
Personal Laptop: 19ms

It's not the modem, and maybe it's not the router...could the problem be the Work Laptop?  Is it a settings issue on the Work Laptop?  Should I do some kind of IPConfigure release (I used to do this like 15 years ago...does this still work?).  Is it the wifi adapter in the laptop?  Do I need to upgrade it?

If it matters, the Work Laptop is a Toshiba and the Personal Laptop is a Dell.  They're both about 5 years old.